Quartus II:
An Introduction for COE 4DM4 LABS

By: Mohammadreza Binesh Marvasti

This document provides a basic introduction to using Quartus II software. The example given has been
used on the latest Quartus II (V.10, V.11 and V.12). This document is broken down into the following

sections.
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1.) Getting Web Version of Quartus

It is assumed that Quartus is already installed onto your computer. If not, Altera has a free version of
Quartus called Quartus IT Web Edition that you can download for free here:
https://www.altera.com/download/software/quartus-ii-we

Just download the Quartus IT Web Edition as shown in the screen capture below.

Download Option 1: Individual Files

Quartus II Web Edition Platform File Name

Quartus II Web Edition Windows 12.0sp2_quartus_free_windows.exe
Service Pack 2 MDS5: 3aa4e0871aaa29ffaeSecd3b42dd6a7b

Quartus II Web Edition Linux 12.0sp2_quartus_free_linux.tar.gz
Service Pack 2 MDS5: eacce40008d33b5eca7277b1f822e621

Note in order to fully download you may need to register at Altera. By clicking “Quartus II Web
edition” it will take to a screen which you can login in to obtain a license file or create a user account.
These steps are intuitive. The goal here is to create an account, download install Quartus II .

Note that in Quartus version 8.1 or newer, a license file is no longer required for Quartus 11 Web
Edition software.

Now, in order to have a simulator installed in your machine, you need also to install the Modelsim-
Altera starter as follows:

Other Individual Download Files:

Quartus II Subscription Edition
ModelSim-Altera
ModelSim-Altera Starter

Nios IT EDS

DSP Builder

Programming Software

Writing a testbench and Setting-up the Modelsim-Altera were provided in a separate video
documentation.




2.) Creating a Quartus Project

Now that Quartus is on your computer and has a valid license, the next step is to create a Quartus
project. Creating a Quartus project is ABSOLUTELY mandatory; otherwise none of the VHDL files
you create or open in Quartus will compile. Think of a Quartus project as a “suitcase” that stores all of
your .vhd (by convention VHDL files have a .vhd extension, not .vhdl), simulation files. In Quartus,
go to File> New Project Wizard, and you’ll be brought to the following screen (if you do no see the
screen below, click NEXT and it will show up):

x|
Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory for this project?
[U:\dDM4\2012\Lab1\Cache

What is the name of this project?

|Cache

What is the name of the top-level design entity for this project? This name is case sensitive and must exactly
match the entity name in the design file.

|Cache _|

Use Existing Project Settings...

< Back Finish Cancel Help

In the first line, identify where you want to store your project on the hard drive. By clicking the icon
with the 3 dots, you can create a new folder to store your project files. In the second line, identify a
name for your project. In this example it is called ‘Cache’. In the third line, identify the top level
entity for the project. Here it is called ‘Cache’. NOTE: It’s not by coincidence that the name of the
project and the top level entity are the same name (that being “Cache”). You MUST make sure that
the project name, the top level entity name, as well as the .vhd that will include the code for your
entity have the SAME name, that being “Cache”. If you don’t use the same name, then your
project won’t compile and you’ll get strange compilation errors.




Click on next and you’ll be brought to the page as shown below:

Add Files [page 2 of 5]

Select the design files you want to include in the project. Click Add Al to add all design files in the project directory to
the project.

Note: you can always add design files to the project later.

File name: | _I Add |

File Name |Type ILibrary IDesign Entry/Synthesis Tool HDL Version Add Al I

Remove

Up |
Down |

Properties

Specify the path names of any non-default lbraries. User Libraries. .. |

< Back | Finish Cancel Help

This page asks you which files you want to include into your project. If you have already made .vhd
file(s) prior to creating the Quartus project, then search for the files in your hard drive that you want to
add to the project by clicking on the icon with the 3 dots. If you haven’t made any .vhd files yet, just
click next.




Next you’ll be brought to a screen asking you to choose which device you want your VHDL code to
compile to, as shown below:

Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.

~Device family ~Show in 'Available devices' list

=100Vl Cvclone 1V GX Package: | Any

Devices: |,=l,H Pin count: IAny

~Target device Speed grade: IAny

&~ Auto device selected by the Fitter WV Show advanced devices

" Specific device selected in 'Available devices' list I” HardCopy: cormpatible orly

€ Other: nfa

Available devices:

Narme Core Voltage | LEs | User [/0s | GXB Transmitter Channel PMA
EP4CGX15BF14C6 | 1.2V 14400 |81 2
EP4CGX15BF14C7 1.2V 14400 |81 |2

FoASSArPE A Ara L4 e 4.AANO A ~

< |

—Companion device

HardCopy:

= Lirnit DSP' & RAM to HardCopy device resolrces

< Back | Next = | Finish I Cancel | Help |

Note that in the web version of Quartus II, only Cyclone family of Altera FPGAs are available.

You just made a Quartus project. This is a crucial step and many students think they can bypass
creating a project and expect that opening a .vhd file in Quartus and clicking “compile” will
automatically compile their .vhd file. Clearly, that won’t work. You must create a Quartus project first.

Summary

So here are the most important points to get out of this section:
1.) you must create a project in Quartus
2.) the name of the Quartus project, the name of top level entity, and the .vhd where you put
your VHDL code for the top level entity must all be the same




3.) Creating a new VHDL file or Opening an existing VHDL file in
Quartus

Before going ahead with this step, make sure that you have a Quartus project already opened. To
create a new VHDL file, go to File-> New, and the following dialog box will appear:

w Ouartus I Project
= Design Files
AHDL File
Block Diagram/Schermatic File
EDIF File
Qsys System File
State Machine File
SystemvVerilog HOL File
Tcl Seript File
VHOL File
Verilog HOL File
=-Memory Files
Hexadecimal (Intel-Format) File
Memory Initialization File
=- Verification/Debugging Files
In-Systemn Sources and Probes File
Logic Analyzer Interface Fie
SignalTap 11 Logic Analyzer File
= Other Files
AHDL Include File
Block Syrmbol File
Chain Description File
Synopsys Design Constraints File
Text File

Cancel

X

Help

Choose “VHDL File” and click ok.
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A new screen will pop up and you can type in your VHDL code.

&, Quartus II - U:/4DM4/2012/Lab1 /temp/Cache - Cache

Fle Edt View Project Assignments Processing Tools Window Hep ®

DR &t erlocllae  Cx¥2@9eT)> % 65(@[8]s]0®
Project Navigator x| & Vhd1.vhd

|5 M T lEE 43R %[0S (R[E= | = =2
1

Entty [
& Cyclone 1V GX: AUTO
» Cache

O Herarchy | B Fies | 6 Design Units

Tasks e x

Flow: [Compiation ~| custornize..

[Task =
& » Comple Design

5 > Analysis & Synthesis
T Edit Settings
EE View Report
¥ Analysis & Elaboration
& W Partition Merge
5 &3 Netfist Viewers
&Q RTL Viewer
& State Machine Viewer _,;l
»

=
s

Ll |
System /\Processng /\ Extra Info /\ Info /\ Warning J\ Criticll Warning /\ Error ]\ Suppressed /\ Flag ]
=i locate

Message: 2| ®|[ocaton
[ 0% 00:00:41
Bt [ oM E@ @O ¢ @ [0 |[@ouartusti-uys,. @ quartus uwebed... | (] o | 1 LIN... b...| £ b_...| @ Downloads | ) 4DM4-INTRO-QUAR.... | - Adobe Acrobat Stan... | 1§ 4.PNG - Paint || SBQD cwm
| Network connections > | controlPanel > |4 @ & S Thursday

| My Computer < Local Disk (C:) ., DVD-RAM Drive (D:) 5% public on 'High Speed Net... S bineshm on High Speed ... (3 Control Panel 4 Administrative Taols & Network Connections .y Printers and Faxes

You can see in the figure above that the default name of the vhd file is Vhdl.vhd. Go to File=> Save
and save the .vhd file to SAME name as your project.

bavens 21|

Save in: ID temp LI & & B~

My Computer

REGES

I EOT  File name: ICache.vhd ZI Save I
El

Cancel |
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Save as type: IVHDL Files [*.vhd *.vhdl)

[V Add file to current project




Make sure “Add file to current project” is checked; otherwise, this .vhd file will not be associated
with the project and you will not be able to compile this VHDL file. (This is a common problem with
many students in the lab—they forget to click “Add file to current project” so when they compile,
they get weird errors about not being able to find the top level entity).

To open an existing .vhd file and to have it associated with your project, go to File=> Open. A dialog
will appear as follows:

Open File

Look in: l_) temp x| « & BB

Recent

Desktop

®

My Documents

o3

My Computer

[EMET S File name: |Cache,vhd Zl Open I
ELES
Files of type: IDesign Files (“.tdf *.vhd *.vhd| “.v “.vlg “.verilog L] Cancel I

[V Add file to current project

IAuto l]

4

Search for the file that you want to add to the project, and REMEMBER to check the “Add file to
current project” checkbox. Click Open or press enter and your .vhd file should now appear in
Quartus.

You can verify with yourself in Quartus to see if your .vhd files are indeed linked to the project by
going to Project Navigator in the Quartus workspace, as shown below (you may need to click on the
middle tab to see it):




Project Navigator

A Files
i Cache.vhd

& Hierarchy Fies | & Design Units |

If you don’t see your file listed in the Project Navigator, then that means the files you created/opened
aren’t linked to the project, which means that you won’t be able to compile your newly created nor
your opened .vhd files. If this is the case, go to File> Open and open your files again, making sure
that you do check on “Add files to Current Project”.

Summary
-Make sure you click on “Add files to Current Project” when opening a .vhd file!




4.) Compiling in Quartus

Now, you’re ready to compile your code (.vhd file(s) associated with a Quartus project). For
compilation you can go to Processing=> Start compilation as shown below.

4, Quartus II - U:/4DM4,/2012/Lab1/temp/Cache - Cache
File Edit View Project Assignments |Processing Tools Window Help &

IDEE@ & %2Rl ™ @ Stop Processing

roject Navigator

‘A Files
i Cache.vhd

coltstiftec | | @ (> W s DH | (8|4 |e|®

Start Compilation
% Analyze Current File
Start
Update Memory Initisization File
& Compiation Report Ctrl+R

Cache.vhd*
%% 0S| R[Ey | 2 =2

gic_1164.ALL;
gic_signed.ALL;
gic_arith.ALL;

&9 PowerPlay Power Analyzer Tool
W SSN Analyzer Tool

ts is
ows : integer:=8; --cache capacity
e_row_format is std_logic_vector (64 downto 0);

USE ieee.
USE ieee.
USE ieee.
use work.

Y —format is array (¢_rows downto 0) of cache_row_format;
\‘end constants;

LIBRARY ieee;

std_logic_1164.ALL;
std_logic_signed.ALL;
std_logic_arith.ALL;
constants.all;

EJENTITY cache IS

You can also press the PLAY icon on the menu bar.




5.) Analysis and Synthesis Settings

To change Analysis & Synthesis settings, on the Assignments menu, click on Settings, and then select
Analysis & Synthesis Settings.

(ol x]
Category:

General Analysis & Synthesis Settings

Fies Specify options for analysis & synthesis. These options control Quartus 11 Integrated Synthesis and do

El)t;frg%i g Settings and Conditic not affect YQM or EDIF netlists unless WYSIWYG primitive resynthesis is enabled.

Voltage
Temperature

Compilation Process Settings  Speed
Early Timing Estimate
Incremental Cornpilation " Balanced
Physical Synthesis Optimiza | | ~ A

= EDA Tool Settings

Design Entry/Synthesis
Simulation

Timing Analysis ¥ Power-Up Don't Care
Formal Verification
I~ Perform WYSIWYG primitive resynthesis

Optimization Technique

v Timing-Driven Synthesis

sis Settings A ot v
VHDL Trput PowerPlay power optimization: |Norma| compiation J

Verilog HOL Input HDL Message Level: Level2 | Advanced...
Default Parameters B I J 4|

Fitter Settings More Settings...
TimeQuest Timing Analyzer

Assembler

Design Assistant

SignalTap 11 Logic Analyzer
Logic Analyzer Interface
PowerPlay Power Analyzer Sett
SSN Analyzer

Description:

Specifies the overall optimization goal for Analysis & Synthesis: atternpt to maximize performance,
minimize logic usage, or balance high performance with minimal logic usage.

i &l oK | Cancel | Apply | Help |
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Quartus II offers different optimization techniques. If resource utilization is an important concern for
you, select Area for the Optimization Technique. If clock frequency is important for you, select the
Speed Optimization Technique option to specify that all combinational logic in or between the
specified clock domain is optimized for speed. For the best trade-off between area and speed, select the
Balanced Optimization Technique. The Balanced setting typically produces utilization results that are
very similar to what produced by the Area setting, but with better performance results.

You can also click on “More Settings” to access more options.




6.) Compliation Report:

After full compilation, click on the “Compilation Report” tab and go to the “Analysis & Synthesis
Resource Utilization” section which yields the screen shown below. It shows the number of LUT-only
LC’s (combinational) and Register-only LC’s. The ‘Logic Cells’ in Cyclone-based FPGAs are
considered as Logic Elements (LE), and in Stratix-based FPGAs are considered as Adaptive Logic
Module (ALM).

The upper-bound of total LC’s is the sum of the two. However, the synthesizer sometimes fits one
combinational LC and one Register LC into one LE or ALM.

#, Quartus II - U;/4DM4,/2012/Lab1 /temp;Cache - Cache
Fie Edit View Project Assignments Processing Tools Window Help

[DZEE 8% B0 ||fcahe Ay s@@e|Tlrw0s & 0se|®

Project Navigator 8| Cache.vhd & Compilation Report (x] I

S Table of Contents Bl Analysis & Synthesis Resource Utilization by Entity
#a Cache.vhd B3 Flow Sumnmary Complation Hierarchy Node LC Combinationals LCRegsters  |Memory Bits_ |DSPElements  |DSP9x9  |DSP 18x18  |DsP 36x36
0

s Cache.sde B2 Flow Settings
* B Fow Non-Default Global Settings |+ L1<2che 14.(14) 00 0 lo 0 o
B Flow Elapsed Time
BB Flow OS Summary
B Flow Log
=& Analysis & Synthesis
B3 Summary
& (] Settings
B8 Paralll Corrpiation
B8 Source Fies Read
BB Resource Usage Summar

IR e Utiization by Entity
- () Optimization Resits
BB Elapsed Time Per Partiion
i) Messages
=+ (1 Fitter
= (O Assernbler
- (3 TimeQuest Timing Analyzer

Below shows an example of analysis & synthesis summery in Cyclone family of FPGAs:

&', Quartus II - U:/4DM4,/2012/Lab1 /temp/Cache - Cache

File Edt View Project Assignments Processing Tools Window Help &

[oERa@ & sb@|oafae ¥ ,@S8R[T[> ¥ 00004 0@
Project Navigator x| & Cache vhd & Cormnpilation Report [x]

2l Analysis & Synthesis Summary

Analysis & Synthesis Status Successful - Fri Oct 05 10:50:48 2012
Quartus 11 Version 11.0 Buid 157 04/27/2011 S Full Version
ER Flow Non-Default Global Settings Revision Name Cache
BB Flow Elapsed Time Top-level Entity Name cache
BB Flow OS Summary Farily Cyclone I¥ GX
B Flow Log Total logic elements
B Analysis & Synthesis Total combinational functions
B3 Summary Dedicated logic registers
#- ( Settings Total registers
EE Parallel Cormpiation Total pins
ER Source Files Read Total virtual pins
BB Resource Usage Summary Total memory bits

A Flles Table of Contents

s Cache.vhd B3 Flow Summary
2: Cache.sdc BB Flow Settings

DO O
o N

ER Resource Utilization by Entity
- () Optimization Resuits
ER Elapsed Time Per Partition
i) Messages
#- (] Fitter

- (21 Assembler
—~—a

Embedded Multiplier 9-bit elements
Total GXB Receiver Channel PCS
Total GXB Receiver Channel PMA
Total GXB Transmitter Channel PCS
Total GXB Transmitter Channel PMA
Total PLLs

cofsfoococoo




7.) Timing Analysis:

After full compilation, from Compilation Report go to “TimeQuest Timing Analyzer” which is shown

IDM4/2012/Lab1 /temp/Cache - Cache
File Edit View Project Assignments Processing Tools

Window Help &

[DEE@ 8] Balo «|[ane

Ay sewe|vlr ¥ oD @@L 0@

Project Navigator 8 x

3 Flles
i Cache.vhd
s Cache.sdc

&
&

Cache.vhd
Table of Contents

OHerarchy B Fies [ & Design Units |

Tasks & x

Flow: [Cornplation

j Customize...

B2 Flow Surnmary

EE Flow Settings

BB Flow Non-Default Global Settings
BB Flow Elapsed Time

EE Flow OS Summary

B Flow Log

(1 Analysis & Synthesis

(X Fitter

(3 Assernbler

A TimeQuest Timing Analyzer

Revision Name
Device Family
Device Name
Timing Models
Delay Model
Rise/Fall Delays

1) - -

ER Paralel Compilation
B3 SDC File List

#- (1 Advanced 1/O Timing
B Clock Transfers
B Report TCCS
B Report RSKM
B8 Unconstrained Paths
i) Messages

& Compiation Report | & Cache.sdc

=l TimeQuest Timing Analyzer Summary

Quartus 11 Version

Version 11.0 Buid 157 04/27/2011 5] Full Version
Cache

Cyclone 1V GX

EP4CGX22CF19C6

Final

Cormbined

Enabled

The TimeQuest timing analyzer offers you some timing models (slow & fast) depending on the
selected device. In each model, the timing specifications for an environment condition are reported.
For example in the figure shown abive, the first model applies when the power voltage is 1200mV and
device temperature is 85 degree Celsius.

By choosing one of the timin

&' Quartus I1

models,

File Edit View Project Assignments Processing Tooks Window Help &

ou will see the following

D@ &% B2@|o o||fcahe

Ay e vrwsD @@ s e|®

Project Navigator

& x

EC
£

Cache.vhd

3 Files
s Cache.vhd

¢ Cache.sdc

Table of Contents

B3 Flow Summary
ER Flow Settings
EE Flow Non-Default Global Settings
ER Flow Elapsed Time
ER Flow OS Summary
B Flow Log
(1 Analysis & Synthesis
(3 Fitter
(3 Assembler
A TimeQuest Timing Analyzer
B3 Summary
ER Parallel Compiation
SDC File List

(1) 3

-3 Slow 120 C Model
B Frnax Summary
B Setup Summary
B Hold Summary
B Recovery Summary
B Removal Summary
Minirmurm Pul fidth Surmmary

O terarchy B Fies | ¢ Design Units |

=3 Datasheet Report

Tasks

& X

B8 Setup Times
B3 Hold Times

Flow: IComp\\auon

j Customize...

B3 Clock to Output Times
B8 Minimum Clock to Output Times

| Task
=- » Cormpile Design
E- P Analysis & Synthesis
[ Edit Settings
B View Report
P Analysis & Elaboration
- W Partition Merge
& {3 Netfist Viewers
& RTL Viewer
@ State Machine Viewer

v
v

il

B8 Propagation Delay
B8 Minimum Propagation Delay
B3 Output Enable Times
B3 Minimum Quiput Enable Times
B3 Qutput Disable Times
B8 Minimum Output Disable Times
B Metastabiity Report
& (3 Slow 1200mYy OC Model
v OC Model
EE Multicorner Timing Anal

Compilation Report

Input Port QOutput Port RR

718 |pcf21]
721 |pcf21]

instr[23]
instr[26]

[13.266
13.266

725 |pc[21]
707 |pc[21]
702 |pc[21]

instr[30]
instr[12]
instr[7]

[13.266
13.264
13.245

722 |pc[21]
708 |pc[21]

instr[27]
instr[13]

13.239
13.226

instr[29]
instr[10]

13.184
13.145

724 |pc[21]
705 |pc[21]

751 |pc[22]
754 |pc[22]
758 |pc[22]

instr[23]
instr[26]
instr[30]

13.073
13.073
13.073

740 |pc[22]
735 |pc[22]

instr[12]
instr[7]

[13.071
13.052

755 |pc[22]
685 |pc[20]
688 |pc[20]
692 |pc[20]
741 |pc[22]

instr[27]
instr[23]
instr[26]
instr[30]
instr[13]

[13.046
13.033
13.033
13.033
13.033

674 |pc[20]
715 |pcf21]

instr[12]
instr[20]

[13.031
13.020

669 |pc[20]
689 |pc[20]
675 |pc[20]

instr[7]
instr[27]
instr[13]

[13.012
13.006
12.993

757 |pc[22]
738 |pc[22]

instr[29]
instr[10]

[12.991
12952

instr[29]
instr[10]

691 |pc[20]
672 |pc[20]

[12.951
12912

—852 |pc[19]

748 |pc[22]
682 |pc[20]

instr[20]
instr[20]
instr[23]

12.827
12.787
12.739

655 |pc[19]
659 |pc[19]

instr[26]
instr[30]

[12.739
12.739

641 |pc[19]
714 |pc[21]

instr[12]
instr[19]

[12.737
12733

| - (1 Mificorner Natasheet Renort Si lmr\i\a:]ﬂ
‘ »

636 |pc[19]
656 |pc[19]
642 |pc[19]

instr[7]
instr[27]
instr[13]

12.718
12.712
12,699




If your design has a clock, you can see setup times, hold times, and maximum frequency of your
design. Otherwise, you should go to the Datasheet Report and see the timing results. The helpful
reports are as follows:

1. Fmax: The maximum clock frequency that can be achieved without violating internal setup
(tsy) and hold (tg) time requirements.
2. Setup Times: Reports the setup times for clocks in the design.
3. Hold Times: Reports the hold times for clocks in the design.
. Propagation Delay: Reports longest delay in nanoseconds between the edges of a signal
propagating from an input port to an output port.
a. RR shows the longest delay measured from rising edge to rising edge
b. RF shows the longest delay measured from rising edge to falling edge
c. FR shows the longest delay measured from falling edge to rising edge
d. FF shows the longest delay measured from falling edge to falling edge
Note that, in the propagation delay the highest delay (Worst-Case) is important.

In the Quartus II you can specify some timing constraints in your design which describe the clock
characteristics, timing exceptions, signal transition arrival and required times. These constraints should
be written with Tcl commands (Tool command Language) and should be saved in a file, named
Synopsys Constraint File (SDC).

The Quartus II assigns a default frequency of 1GHz (1ns) for clocks that have not been constrained,

unless any constraint exists in the design.




8.) RTL Viewer:

RTL Viewer can be accessed through the Tools menu and open “Netlist Viewer” then click on RTL

Viewer.

4, Quartus II - U:/4DM4/2012/Lab1/temp/Cache - Cache

File Edit View Project Assignments Processing [ Tools Window Help &
|IDeR@ &| & B@R|w o|||cahe Run EDA Simulation Tool
Project Navigator Run EDA Timing Analysis Tool

P ) o ’
=4 Fies % Launch EDA Simulation Library Cormpiler

i Cache.vhd K2 Launch Design Space Explorer

> @®|s|e(®

&3 TimeQuest Timing Analyzer

Advisors

& Chip Planner (Floorplan and Chip Editor)
€ Design Partition Planner

1 SignalTap 11 Logic Analyzer

@@ [n-System Memory Content Editor

[w] Logic Analyzer Interface Editor

[ In-System Sources and Probes Editor
SignalProbe Pins...

& Programmer

@ JTAG Chain Debugger

9.) Floorplan Editor:

whd &

Flow Status
Quartus IT Version
Revision Name
Top-level Entity Name
Family
= Total logic elements
Total combinational functions

Dedicated logic registers
r
& State Machine Viewer
& Technology Map Viewer (Post-Mapping)
& Technology Map Viewer (Post-Fitting)

Compiation Report

Successful - Thu Oct 04 19:35:44 2012
11.0 Build 157 04,/27/2011 S Full Yersion
Cache

cache

Cyclone IV GX

14 /21,280 (< 1%)

14 /21,280 (< 1% )

0/21,280 (0%)

/167 (40 % )
774,144 (0 % )

30 (0% )
4(0%)

Total GXB Transmitter Channel PCS
Total GXB Transmitter Channel PMA
Total PLLs

Device

Timing Models

¥4(0%)
0/4(0%)
0/4(0%)
0/4(0%)
EP4CGX22CF19C6
Final

Floorplan editor can be accessed through the Tools menu and click “Chip Planner”.

!, Quartus II - U;/4DM4/2012/Lab1 /temp/Cache - Cache
File Edit View Project Assignments Processing | Tools Window Hep &

ISR @& % B@|w o ||cahe Run EDA Sirmulation Tool

D (@04 e|®

Project Navigator Run EDA Timing Analysis Tool
2. Launch EDA Simulation Library Compiler
B2 Launch Design Space Explorer

| @

3 Files
e Cache.vhd

&3 TimeQuest Timing Analyzer

Advisors

%] Chip Pla

& Design Partition Planner
Netiist Viewers

1 SignalTap I Logic Analyzer

& In-System Memory Content Editor

[w] Logic Analyzer Interface Editor

[*4] In-System Sources and Probes Editor
SignalProbe Pins...

& Programmer

@b JTAG Chain Debugger

S Transceiver Tookit

¢ External Memory Interface Tookit

& Herarchy
Tasks

B Fles | 6 Design Units |

“{ MegaWizard Plug-In Manager
Nios 11 Software Build Tools for Eclipse
=] Custom 13 SOPC Biider
% Qsys
. Tl Scripts...

Flow: [Compilation

| Task
v | E-» Compile Design

Compilation Report

Chip Planner (x] I

Editing Mode: |ECO - EP4CGX22CF19C6 [~

v S » Analysis & Synthesis

Customize...
Options. ..
License Setup...

[ Edit Settings

ER View Report.

P Analysis & Elaboration
& W Partition Merge
B 3 Netiist Viewers

T T Satiree File

Netlist Type Color

Q RTL Viewer

=
Eol % &I Fommendation: 1 of 1 for [Al Design Partitions
& State Machine Viewer (a]

=
=
;l_l

Locate History I LogicLock Regions Window I Change Manager

=] | ¥ [Tine selected partitons already match the recommendations

Design Partitions Window I




In this figure, each rectangular denotes an Array Logic Block (ALB). In each ALB, there are some LEs
or ALMs. Each dark blue rectangular represents a used ALB in your current design. If you zoom-in the
floorplan, as shown in below, you can see the used ALMs or LEs in an ALB.

Editing Mode: IECO - EP4CGX22CF19CE

(37, 37)
Block utiization: 0 of 32
Resource: LAB_X37_Y37_NO

FIEleslxr ¥y Rlls G L=dal[al

@z

Hopefully, this tutorial has given you enough information to get started with both VHDL and Quartus.




